Page 1 of 1

bricked!!!!

PostPosted: Fri Sep 30, 2016 5:23 am
by rhwestfall
I have a CooTwo from the funding campaign. It was fine this spring, and used for the first time. Regrettably, it was misplaced and not found until last week. In charging it, it took 24 hours to even get a green light on the body when hooked up, but would not turn on. Another 24 hours on the charger and still nothing. When unplugging it, it flashes a line on the screen. Another 24 hours, and still nothing. I opened it to see if the battery had become unseated as reported in some instances, and it was fine. I swapped it with an eLoop, and nothing. I also tried a standard alkaline cell, and nothing...

Please advise.

Re: bricked!!!!

PostPosted: Fri Sep 30, 2016 7:48 am
by rhwestfall
okay, my bad... AAA are not the voltage necessary. Trying to locate 10440's to swap in a new battery. It may be that the OEM cell has fully discharged and been ruined as they are not protected cells.

Re: bricked!!!!

PostPosted: Thu Apr 11, 2019 2:58 pm
by adam13
I had the same thing happen. I took out the battery and was able to charge it fine in a Li ion charger and now it works fine. It seems that a deep discharged battery may be recovered if charged out of the Cootwo. In my case I charged the battery in a VP2 Xtar charger at 0.25 amp.

Adam